加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
克隆/下载
oec-hardware.spec 8.26 KB
一键复制 编辑 原始数据 按行查看 历史
Shine.Wang 提交于 2024-09-25 15:51 . update-v1.1.6
%global _build_id_links none
%undefine __brp_mangle_shebangs
%define vendor %{?_vendor:%{_vendor}}%{!?_vendor:openEuler}
%define vendor_lowercase %{?_vendor:%(echo %{_vendor} | tr '[:upper:]' '[:lower:]')}%{!?_vendor:openeuler}
Name: oec-hardware
Summary: openEuler Hardware Compatibility Test Suite
Version: 1.1.6
Release: 0
Group: Development/Tools
License: Mulan PSL v2
URL: https://gitee.com/openeuler/oec-hardware
Source0: https://gitee.com/openeuler/oec-hardware/repository/archive/v%{version}.tar.gz
# patch fix issue
Buildroot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: gcc
Requires: kernel-devel, kernel-headers, dmidecode, tar
Requires: kernel >= 4
Requires: python3, python3-pyyaml, python3-concurrent-log-handler, net-tools
Provides: libswsds.so()(64bit)
# server subpackage
%package server
Summary: openEuler Hardware Compatibility Test Server
Group: Development/Tools
Requires: python3, python3-devel, python3-flask, python3-uWSGI, python3-werkzeug
Requires: nginx, tar, qperf, psmisc, dpdk, dpdk-tools, dpdk-devel, net-tools, perftest
%description
openEuler Hardware Compatibility Test Suite
%description server
openEuler Hardware Compatibility Test Server
%prep
%setup -q -c
%build
%ifarch x86_64 aarch64
strip tests/compatible/keycard/libswsds_%{_arch}.so
%endif
sed -i '15i CFLAGS+=-g -fstack-protector-strong' tests/compatible/memory/Makefile
[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
DESTDIR=$RPM_BUILD_ROOT VERSION_RELEASE=%{version} make
%install
DESTDIR=$RPM_BUILD_ROOT make install
# Custom vendor
sed -i 's#grep openeulerversion /etc/openEuler-latest#grep %{vendor_lowercase}version /etc/%{vendor}-latest#g' %{buildroot}/usr/share/oech/lib/hwcompatible/cert_info.py
%clean
[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
%pre
%post
%files
%defattr(-,root,root)
/usr/bin/oech
/usr/share/oech/kernelrelease.json
/usr/share/oech/lib/hwcompatible
/usr/share/oech/lib/tests
/usr/share/oech/lib/config
/usr/lib/systemd/system/oech.service
/usr/share/oech/lib/oech_logrotate.sh
%dir /var/oech
%dir /usr/share/oech/lib
%dir /usr/share/oech
%files server
%defattr(-,root,root)
/usr/bin/oech-server
/usr/share/oech/lib/server
/usr/share/oech/lib/config
/usr/lib/systemd/system/oech-server.service
%postun
rm -rf /var/lock/oech.lock
%changelog
* Tue Sep 24 2024 wangshuai <wangshuai321@huawei.com> - 1.1.6-0
- Add new test suite srpm and intel
- Add virtual branch of test suite
- Add support for Kylin and UOS
- Bugfix
* Fri Jun 7 2024 xiaochn <xiaochuannan@inspur.com> - 1.1.5-4
- Resolve the issue of executing Vulkan even if DISPLAY is not defined in the env
* Tue Jun 4 2024 xiaochn <xiaochuannan@inspur.com> - 1.1.5-3
- Resolve the issue of different kernel source download locations in kabi test case
- Resolve the issue that kabiwhitelist still passes when the ko and rpm file does not exist
- Add the way for manually adding kabiwhitelist file
- For custom vendors, refer to the method of obtaining openEuler os information
- Supports custom vendor
* Wed Nov 29 2023 cuixucui <cuixucui@h-partner.com> - 1.1.5-1
- Resolve kdump\watchdog\cpufreq\kabiwhitelist\network test failure issue
- Add fio test cases:read,write,randread,randwrite
- Solve the nvme line break issue in the command line interface
- Fix compilation errors in the make command
- Add Vulkan testcase for nvida GPU
- Resolve the issue of oech server startup failure on version 24.03
* Wed Nov 29 2023 cuixucui <cuixucui@h-partner.com> - 1.1.5-1
- Add virtual cases
- Resolve IB startup IB_Read_BW service failure issue
- Delete redundant references
- Resolve incorrect type in vgpu result data
- Resolve the issue of getting the kernel source rpm
* Tue Oct 24 2023 cuixucui <cuixucui@h-partner.com> - 1.1.5-0
- Add support for openEuler 20.03 LTS SP4, openEuler 22.03 LTS SP2, openEuler 22.03 LTS SP3
- Add modifications to Kylinsec with oec-hardware
- Add support for Loongson and SW architectures
- Bugfix
* Tue Feb 28 2023 cuixucui <cuixucui1@h-partner.com> - 1.1.4-0
- Add board information in the test report
- Add spdk test case
- Add dpdk test case
- Update pci.ids file
* Tue Dec 13 2022 liqiang <liqiang332@h-partner.com> - 1.1.3-3
- Fix libswsds.so not stripped
- Fix the value of kernel.src obtained by the kabi test case is incorrect
- Add board infomation and fix memory bug
- Fix the block size fails to be obtained during the NVME test
- Judge whether to support kabi testing by architecture
- Update readme and dev_design
* Wed Nov 09 2022 cuixucui <cuixucui1@h-partner.com> - 1.1.3-2
- Fix code issue and update log print in network
- Cancel deleting the IP that automatically configured on the server
- Fix cdrom bug
* Wed Oct 26 2022 cuixucui <cuixucui1@h-partner.com> - 1.1.3-1
- Add default values to the parameters of get_disk function
* Mon Oct 24 2022 zhangyale <zhangyale3@h-partners.com> - 1.1.3-0
- Add support for openEuler 22.03 LTS SP1
- Add AMD GPU testcase
- Add automatic configuration network card IP
- Add generate compatibility information
* Mon Oct 10 2022 cuixucui <cuixucui1@h-partners.com> - 1.1.2-5
- fix the bug that the test board information is not added to the configuration file
- Add kabi for hardware critical test
- Optimize disk/raid/fc/ethernet/infiniband test suite
- Fix the bug of reading nvme data failed
- Add file size check when uploading file to server
* Wed Sep 21 2022 cuixucui <cuixucui1@h-partners.com> - 1.1.2-4
- Add requirements for system and bugfix
- Upgrade oec-hardware-server
- Update readme and design doc
- Fix nvme error
- Update network fibre check and log
- Update description for perf test
- Add automatic configuration network card IP
* Tue Sep 06 2022 meitingli <bubble_mt@outlook.com> - 1.1.2-3
- Add generate compatibility information
- Fix gpu and keycard issues
* Mon Sep 05 2022 cuixucui <cuixucui1@h-partners.com> - 1.1.2-2
- Fix Check whether the tool is modified failed
* Sat Sep 03 2022 ylzhangah <zhangyale3@h-partners.com> - 1.1.2-1
- Fix the status failed in checking oech.service status after stoped oech.service
* Tue Aug 30 2022 ylzhangah <zhangyale3@h-partners.com> - 1.1.2-0
- Upgrade command module
- Add VGPU testsuite
- Bugfix;
* Wed Aug 24 2022 wangkai <wangkai385@h-partners.com> - 1.1.1-6
- Enable debuginfo for fix strip
* Wed Aug 17 2022 zhangzikang <zhangzikang@kylinos.cn> - 1.1.1-5
- Fix server.py variable conflict issues in some system environment
* Wed Aug 10 2022 ylzhangah <1194926515@qq.com> - 1.1.1-4
- Fix rebootup issues
- Fix the issue that oech.service cannot be started
* Wed Aug 3 2022 cuixucui <cuixucui1@h-partners> - 1.1.1-3
- Fix the problem that the client fails to send messages after the server port is modified
- Fix the problem that the system test item failed to check the integrity of the software package
* Mon Aug 1 2022 cuixucui <cuixucui1@h-partners> - 1.1.1-2
- Fix the problem that FC and raid cannot get the new hard disk partition
* Sat Jul 30 2022 ylzhangah <1194926515@qq.com> - 1.1.1-1
- Change the version in version.config to 1.1.1
* Wed Jul 27 2022 cuixucui <cuixucui1@h-partners.com> - 1.1.1-0
-1. Reconstruct the log module and rectify the log printing
-2. Add kabi testcase
-3. Add driver, driver version, chip and module display to the console
-4. Add configuration file for testsuite to improve automation rate
-5. Add oech and oech-server version display
-6. Add driver information display in hardware test logs
* Fri Jul 08 2022 meitingli <bubble_mt@outlook.com> - 1.1.0-1
- Fix oech.server message display, change python version to python3
* Mon May 30 2022 meitingli <bubble_mt@outlook.com> - 1.1.0-0
- 1. Add support os version: openEuler 22.03LTS
- 2. Add FC/RAID/keycard/GPU/infiniband testcases
- 3. Bugfix
* Thu Sep 09 2021 Cui XuCui <cuixucui1@huawei.com> - 1.0.0-8
* Thu Jul 15 2021 zhangzikang <zhangzikang@kylinos.cn> - 1.0.0-7
- Fix cdrom and cpufreq test failed
* Fri Mar 19 2021 caodongxia <caodongxia@huawei.com> - 1.0.0-6
* Tue Sep 29 2020 Cui XuCui <cuixucui1@huawei.com> - 1.0.0-5
* Fri Jul 24 2020 Cui XuCui <cuixucui1@huawei.com> - 1.0.0-4
* Sun Jul 18 2020 Cui XuCui <cuixucui1@huawei.com> - 1.0.0-3
* Wed Jul 01 2020 Cui XuCui <cuixucui1@huawei.com> - 1.0.0-2
* Fri Jul 26 2019 Lu Tianxiong <lutianxiong@huawei.com> - 1.0.0-h1
- Initial spec
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化