加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-pulsectl.spec 3.37 KB
一键复制 编辑 原始数据 按行查看 历史
Jason_828e 提交于 2023-07-31 12:33 . update version to 23.5.2
%global _empty_manifest_terminate_build 0
Name: python-pulsectl
Version: 23.5.2
Release: 1
Summary: Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)
License: MIT
URL: http://github.com/mk-fg/python-pulse-control
Source0: https://files.pythonhosted.org/packages/8d/df/73af0b1a7d9f29b97c9a78ef871767bfb02e90b6fde673b0228495fab214/pulsectl-23.5.2.tar.gz
BuildArch: noarch
%description
Python (3.x and 2.x) blocking high-level interface and ctypes-based bindings
for PulseAudio_ (libpulse), to use in a simple synchronous code.
Wrappers are mostly for mixer-like controls and introspection-related operations,
as opposed to e.g. submitting sound samples to play and player-like client.
For async version to use with asyncio_, see `pulsectl-asyncio`_ project instead.
Originally forked from pulsemixer_ project, which had this code bundled.
|
%package -n python3-pulsectl
Summary: Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)
Provides: python-pulsectl
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-pulsectl
Python (3.x and 2.x) blocking high-level interface and ctypes-based bindings
for PulseAudio_ (libpulse), to use in a simple synchronous code.
Wrappers are mostly for mixer-like controls and introspection-related operations,
as opposed to e.g. submitting sound samples to play and player-like client.
For async version to use with asyncio_, see `pulsectl-asyncio`_ project instead.
Originally forked from pulsemixer_ project, which had this code bundled.
|
%package help
Summary: Development documents and examples for pulsectl
Provides: python3-pulsectl-doc
%description help
Python (3.x and 2.x) blocking high-level interface and ctypes-based bindings
for PulseAudio_ (libpulse), to use in a simple synchronous code.
Wrappers are mostly for mixer-like controls and introspection-related operations,
as opposed to e.g. submitting sound samples to play and player-like client.
For async version to use with asyncio_, see `pulsectl-asyncio`_ project instead.
Originally forked from pulsemixer_ project, which had this code bundled.
|
%prep
%autosetup -n pulsectl-23.5.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pulsectl -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Aug 01 2023 chenzixuan <chenzixuan@kylinos.cn> - 23.5.2-1
- Type:update
- ID:NA
- SUG:NA
- DESC:update to 23.5.2
* Tue Jul 12 2022 cuiyudong <cuiyudong@kylinos.cn> - 22.3.2-1
- Type:update
- ID:NA
- SUG:NA
- DESC:initial for Euler
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化