加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
tracetools-trace.spec 2.65 KB
一键复制 编辑 原始数据 按行查看 历史
郑俊杰 提交于 2023-05-12 16:52 . add all
%bcond_without tests
%bcond_without weak_deps
%global debug_package %{nil}
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
%define RosPkgName tracetools-trace
Name: ros-%{ros_distro}-%{RosPkgName}
Version: 4.1.1
Release: 1%{?dist}%{?release_suffix}
Summary: Tools for setting up tracing sessions.
Url: https://index.ros.org/p/tracetools_trace/
License: Apache 2.0
Source0: %{name}_%{version}.orig.tar.gz
Requires: python3-lttng
Requires: ros-%{ros_distro}-ros-workspace
BuildRequires: ros-%{ros_distro}-ros-workspace
%if 0%{?with_tests}
BuildRequires: ros-%{ros_distro}-ament-copyright
BuildRequires: ros-%{ros_distro}-ament-flake8
BuildRequires: ros-%{ros_distro}-ament-mypy
BuildRequires: ros-%{ros_distro}-ament-pep257
BuildRequires: ros-%{ros_distro}-ament-xmllint
BuildRequires: python3-pytest
%endif
Provides: %{name}-devel = %{version}-%{release}
Provides: %{name}-doc = %{version}-%{release}
Provides: %{name}-runtime = %{version}-%{release}
%description
Tools for setting up tracing sessions.
%prep
%autosetup -p1
%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree and source it. It will set things like
# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
%py3_build
%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree and source it. It will set things like
# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
%py3_install -- --prefix "/opt/ros/%{ros_distro}"
%if 0%{?with_tests}
%check
# Look for a directory with a name indicating that it contains tests
TEST_TARGET=$(ls -d * | grep -m1 "\(test\|tests\)" ||:)
if [ -n "$TEST_TARGET" ] && %__python3 -m pytest --version; then
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree and source it. It will set things like
# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
%__python3 -m pytest $TEST_TARGET || echo "RPM TESTS FAILED"
else echo "RPM TESTS SKIPPED"; fi
%endif
%files
/opt/ros/%{ros_distro}
%changelog
* Thu May 04 2023 Christophe Bedard bedard.christophe@gmail.com - 4.1.1-1
- Autogenerated by ros-porting-tools
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化