加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-dbfread.spec 1.92 KB
一键复制 编辑 原始数据 按行查看 历史
jwhl 提交于 2021-10-12 20:24 . commit package
# Created by pyp2rpm-3.3.7
%global pypi_name dbfread
%global pypi_version 2.0.7
Name: python-%{pypi_name}
Version: %{pypi_version}
Release: 1
Summary: Read DBF Files with Python
License: MIT
URL: https://dbfread.readthedocs.io/
Source0: dbfread-2.0.7.tar.gz
BuildArch: noarch
BuildRequires: python3-devel
BuildRequires: python3dist(setuptools)
BuildRequires: python3dist(sphinx)
%description
dbfread - Read DBF Files with Python DBF is a file format used by databases
such dBase, Visual FoxPro, and FoxBase+. This library reads DBF files and
returns the data as native Python data types for further processing. It is
primarily intended for batch jobs and one-off scripts.:: >>> from dbfread
import DBF >>> for record in DBF('people.dbf'): ... print(record)
OrderedDict([('NAME', 'Alice'),...
%package -n python3-%{pypi_name}
Summary: %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}
%description -n python3-%{pypi_name}
dbfread - Read DBF Files with Python DBF is a file format used by databases
such dBase, Visual FoxPro, and FoxBase+. This library reads DBF files and
returns the data as native Python data types for further processing. It is
primarily intended for batch jobs and one-off scripts.:: >>> from dbfread
import DBF >>> for record in DBF('people.dbf'): ... print(record)
OrderedDict([('NAME', 'Alice'),...
%prep
%autosetup -n %{pypi_name}-%{pypi_version}
%build
%py3_build
# generate html docs
PYTHONPATH=${PWD} sphinx-build-3 docs html
# remove the sphinx-build leftovers
rm -rf html/.{doctrees,buildinfo}
%install
%py3_install
%check
%{__python3} setup.py test
%files -n python3-%{pypi_name}
%license docs/license.rst LICENSE
%doc README.rst
%{python3_sitelib}/%{pypi_name}
%{python3_sitelib}/%{pypi_name}-%{pypi_version}-py%{python3_version}.egg-info
%changelog
* Tue Oct 12 2021 shilei <shileib@uniontech.com> - 2.0.7-1
- Initial package.
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化