代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/python-dbfread 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
# Created by pyp2rpm-3.3.7
%global pypi_name dbfread
%global pypi_version 2.0.7
Name: python-%{pypi_name}
Version: %{pypi_version}
Release: 1
Summary: Read DBF Files with Python
License: MIT
URL: https://dbfread.readthedocs.io/
Source0: dbfread-2.0.7.tar.gz
BuildArch: noarch
BuildRequires: python3-devel
BuildRequires: python3dist(setuptools)
BuildRequires: python3dist(sphinx)
%description
dbfread - Read DBF Files with Python DBF is a file format used by databases
such dBase, Visual FoxPro, and FoxBase+. This library reads DBF files and
returns the data as native Python data types for further processing. It is
primarily intended for batch jobs and one-off scripts.:: >>> from dbfread
import DBF >>> for record in DBF('people.dbf'): ... print(record)
OrderedDict([('NAME', 'Alice'),...
%package -n python3-%{pypi_name}
Summary: %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}
%description -n python3-%{pypi_name}
dbfread - Read DBF Files with Python DBF is a file format used by databases
such dBase, Visual FoxPro, and FoxBase+. This library reads DBF files and
returns the data as native Python data types for further processing. It is
primarily intended for batch jobs and one-off scripts.:: >>> from dbfread
import DBF >>> for record in DBF('people.dbf'): ... print(record)
OrderedDict([('NAME', 'Alice'),...
%prep
%autosetup -n %{pypi_name}-%{pypi_version}
%build
%py3_build
# generate html docs
PYTHONPATH=${PWD} sphinx-build-3 docs html
# remove the sphinx-build leftovers
rm -rf html/.{doctrees,buildinfo}
%install
%py3_install
%check
%{__python3} setup.py test
%files -n python3-%{pypi_name}
%license docs/license.rst LICENSE
%doc README.rst
%{python3_sitelib}/%{pypi_name}
%{python3_sitelib}/%{pypi_name}-%{pypi_version}-py%{python3_version}.egg-info
%changelog
* Tue Oct 12 2021 shilei <shileib@uniontech.com> - 2.0.7-1
- Initial package.
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。