代码拉取完成,页面将自动刷新
# Testsuite is CPU and disk space intensive, partially also just broken
%{!?testsuite: %global testsuite 1}
Summary: Utility to clone and restore a partition
Name: partclone
Version: 0.3.32
Release: 1
# Partclone itself is GPL-2.0-or-later but uses other source codes, breakdown:
# GPL-3.0-or-later: fail-mbr/fail-mbr.S
# BSD-2-Clause AND GPL-2.0-only AND GPL-2.0-or-later AND LGPL-3.0-or-later: src/btrfs*
# GPL-2.0-or-later: src/exfat*
# GPL-2.0-only: src/f2fs/
# GPL-1.0-or-later AND GPL-2.0-only AND GPL-2.0-or-later AND LGPL-2.1-only: src/xfs*
# GPL-2.0-or-later: src/{apfs,dd,extfs,fat,f2fs,hfsplus,minix,nilfs,ntfsclone-ng,part}clone*
# GPL-2.0-or-later: src/{{fuseimg,info,main,ntfsfixboot,readblock}.c,progress*}
# LGPL-2.0-or-later: src/gettext.h
# Unused source code (= not built): src/{jfs,reiser,ufs,vmfs}*
License: BSD-2-Clause AND GPL-1.0-or-later AND GPL-2.0-only AND GPL-2.0-or-later AND GPL-3.0-or-later AND LGPL-2.1-only AND LGPL-2.0-or-later AND LGPL-3.0-or-later
URL: http://partclone.org/
Source0: https://github.com/Thomas-Tsai/partclone/archive/%{version}/%{name}-%{version}.tar.gz
BuildRequires: gcc
BuildRequires: libuuid-devel
BuildRequires: fuse-devel
BuildRequires: ncurses-devel
BuildRequires: openssl-devel
BuildRequires: e2fsprogs-devel
BuildRequires: ntfs-3g-devel
BuildRequires: libblkid-devel
BuildRequires: bash-completion
%if 0%{?testsuite}
BuildRequires: e2fsprogs
BuildRequires: ntfsprogs
BuildRequires: dosfstools
BuildRequires: hfsplus-tools
BuildRequires: xfsprogs
BuildRequires: btrfs-progs
BuildRequires: f2fs-tools
%endif
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: gettext-devel
Provides: bundled(libbtrfs)
Provides: bundled(libbtrfsutil)
Provides: bundled(xfsprogs-libs)
%description
Partclone provides utilities to clone and restore used blocks on a partition
and is designed for higher compatibility of the file system by using existing
libraries, e.g. e2fslibs is used to read and write the ext2 partition.
%prep
%autosetup -p1
autoreconf -i -f
%build
# /usr/include/asm/types.h:31 and xfs/platform_defs.h:50 try both to define
# umode_t, reported: https://github.com/Thomas-Tsai/partclone/issues/96
%configure \
--enable-extfs \
--enable-xfs \
--disable-reiserfs \
--disable-reiser4 \
--enable-hfsp \
--enable-fat \
--disable-exfat \
--enable-f2fs \
--disable-nilfs2 \
--enable-ntfs \
--disable-ufs \
--disable-vmfs \
--disable-jfs \
--enable-btrfs \
--enable-minix \
--enable-ncursesw \
--enable-fs-test
# https://forum.slitaz.org/topic/parclone-needs-to-be-rebuilded
sed -i 's|exit 1|exit 0|' fail-mbr/compile-mbr.sh
%make_build
%install
%make_install
mv -f $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/%{name}{-prompt,}
# Building fail-mbr.bin requires a compiler that can build x86 binaries
%ifnarch %{ix86} x86_64
rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/
%endif
%find_lang %{name}
%if 0%{?testsuite}
%check
# Patch proposal submitted: https://github.com/Thomas-Tsai/partclone/issues/103
sed -e 's/256/1440/' -i tests/_common
# Tests for Btrfs, XFS and F2FS filesystems are broken on all architectures
sed -e 's/^\(am__append_[[:digit:]]* = btrfs.test\)/#\1/' \
-e 's/^\(am__append_[[:digit:]]* = xfs.test\)/#\1/' \
-e 's/^\(am__append_[[:digit:]]* = f2fs.test\)/#\1/' \
-e 's/^\(am__append_[[:digit:]]* = btrfs.test\)/#\1/' \
-i tests/Makefile
# NILFS2 tests must be run as root (mockbuild is unprivileged)
sed -e 's/^\(am__append_[[:digit:]]* = nilfs2.test\)/#\1/' \
-i tests/Makefile
# Reiser4 tests require reiser4progs (which are not packaged)
sed -e 's/^\(am__append_[[:digit:]]* = reiser4.test\)/#\1/' \
-i tests/Makefile
# Tests for FAT and HFS+ filesystems are broken on ppc64 and s390x
%ifarch ppc64 s390x
sed -e 's/^\(am__append_[[:digit:]]* = fat.test\)/#\1/' \
-e 's/^\(am__append_[[:digit:]]* = hfsplus.test\)/#\1/' \
-i tests/Makefile
%endif
make check || (cat tests/test-suite.log; exit 1)
%endif
%files -f %{name}.lang
%license COPYING
%doc AUTHORS ChangeLog
%{_datadir}/bash-completion/completions/%{name}
%{_sbindir}/%{name}.*
%ifarch %{ix86} x86_64
%{_datadir}/%{name}/
%endif
%{_mandir}/man8/%{name}*.8*
%changelog
* Mon Oct 21 2024 yaoxin <yao_xin001@hoperun.com> - 0.3.32-1
- Update to 0.3.32
* update hfsplus log
* fix ntfs error for ' read error: Success'
* add option prog_second to display in seconds
* Fix tiny resource leak. by @TMR5454 in #248
* Add missing return in libvmfs_version(). by @TMR5454 in #249
* Fix get_exec_name(): when partclone in installed, there is no '/' in argv0 by @pfrouleau in #55
* Include the NTFS Boot Record backup in the cloned image by @pfrouleau in #54
* Mon Oct 09 2023 yaoxin <yao_xin001@hoperun.com> - 0.3.27-1
- Upgrade to 0.3.27
* Thu Mar 10 2022 liyanan <liyanan32@huawei.com> - 0.3.12-4
- Fix build error
* Tue Aug 3 2021 weidong <weidong@uniontech.com> - 0.3.12-3
- Fix link failuer with gcc-10
* Fri Nov 6 2020 weidong <weidong@uniontech.com> - 0.3.12-2
- Modify buildrequires
* Fri Aug 7 2020 weidong <weidong@uniontech.com> - 0.3.12-1
- Initial release for OpenEuler
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。