加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-cvss.spec 3.23 KB
一键复制 编辑 原始数据 按行查看 历史
zhaosai 提交于 2024-11-05 16:16 . Upgrade to the latest version 3.3
%global _empty_manifest_terminate_build 0
Name: python-cvss
Version: 3.3
Release: 1
Summary: CVSS2/3 library with interactive calculator for Python 2 and Python 3
License: LGPLv3+
URL: https://github.com/skontar/cvss
Source0: https://files.pythonhosted.org/packages/source/c/cvss/cvss-%{version}.tar.gz
BuildArch: noarch
%description
This Python package contains CVSS v2 and v3 computation utilities and
interactive calculator compatible with both Python 2 and Python 3.
The library is tested on all currently-supported Python versions available
via GitHub Actions (with the exception of Python 2.7, which is EOL but
still tested against), but it is simple enough to run on even older versions.
%package -n python3-cvss
Summary: CVSS2/3 library with interactive calculator for Python 2 and Python 3
Provides: python-cvss = %{version}-%{release}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-cvss
This Python package contains CVSS v2 and v3 computation utilities and
interactive calculator compatible with both Python 2 and Python 3.
The library is tested on all currently-supported Python versions available
via GitHub Actions (with the exception of Python 2.7, which is EOL but
still tested against), but it is simple enough to run on even older versions.
%package help
Summary: Development documents and examples for cvss
Provides: python3-cvss-doc
%description help
This Python package contains CVSS v2 and v3 computation utilities and
interactive calculator compatible with both Python 2 and Python 3.
The library is tested on all currently-supported Python versions available
via GitHub Actions (with the exception of Python 2.7, which is EOL but
still tested against), but it is simple enough to run on even older versions.
%prep
%autosetup -n cvss-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cvss -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Nov 05 2024 zhaosaisai <zhaosaisai@kylinos.cn> - 3.3-1
- Upgrade to the latest version 3.3
- Implemented correct eq methods
- Added methods for isolated temporal and environmental vectors
- Another rounding fix
* Thu Mar 2 2023 wubijie <wubijie@kylinos.cn> - 2.6-1
- Update package to version 2.6
* Thu Nov 03 2022 guozhengxin <guozhengxin@kylinos.cn> - 2.5-1
- Upgrade package to version 2.5
* Mon Jul 05 2021 liliang <liliang@kylinos.cn> - 2.3-1
- Init project
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化